ALT LTD (trading as 'Ctrl Alt') is a company Registered in England and Wales (company number 12481559) with a registered address of Alt Ltd, 86-90 Paul Street, London, England, EC2A 4NE.
Ctrl Alt Solutions DMCC (trading as 'Ctrl Alt') is a company registered in the UAE (company number DMCC199928) with a registered address of Ctrl Alt Solutions DMCC, Unit No: UT-12-PO-12, DMCC Business Centre, Level No. 12, Uptown Tower, Dubai, U.A.E.
Ctrl Alt Solutions DMCC (Ctrl Alt) is licensed by Dubai's Virtual Assets Regulatory Authority (VARA) for Broker Dealer Services since 24th May 2025 with VASP licence number VL/25/05/002
Don’t invest unless you are prepared to lose all the money you invest. This is a high risk investment. Alt Ltd facilitate the Ctrl Alt app. Alt Ltd (FRN: 974321) is an Appointed Representative of Infinity Asset Management LLP, a Firm authorised and regulated by the Financial Conduct Authority (FRN: 464315). Ctrl Alt does not provide investment advice and/or recommendations, and, no communication, through its App or website or otherwise, should be construed as a recommendation of any security. Individual investors should make their own decisions or seek professional independent advice if they are unsure as to the suitability / appropriateness of any investment for their individual circumstances or needs, including potential tax treatment. The value of an investment may go down as well as up and past performance is not a reliable indicator of future results. Access to this platform and the underlying assets is subject to eligibility. See our terms and conditions for further detail. Alt Ltd, 86-90 Paul Street, London, England, EC2A 4NE.
© Ctrl Alt – 2025
Primary AWS platform availability remains largely unchanged, though communications with their regional recovery teams are ongoing.
Our contingency infrastructure is in a strong position, with backup systems and data environments largely in place. We have been working closely with our partners to complete final validation steps, and are awaiting regulatory approval to proceed with the final stages of resumption of services.
We will post a further update as soon as there is meaningful progress to report.
Monitoring
Primary AWS platform availability remains largely unchanged, though communications with their regional recovery teams are ongoing.
Our contingency infrastructure is in a strong position, with backup systems and data environments largely in place. We have been working closely with our partners to complete final validation steps, and are awaiting regulatory approval to proceed with the final stages of resumption of services.
We will post a further update as soon as there is meaningful progress to report.
Monitoring
Primary AWS platform availability remains largely unchanged. In parallel, our efforts to implement backup infrastructure have been progressing, with thorough data validation processes now in the final stages of completion.
AWS recovery efforts are ongoing, and we continue to monitor developments closely. In light of the timeline for full regional restoration, we are actively progressing our contingency infrastructure plan, migrating applications to our alternative data centre and data and document storage.
Our data environment is in a strong position, and pending final validation checks over the coming days, we are confident that we have everything required to support the resumption of services. We are working through the remaining steps and will provide an update as soon as we are in a position to confirm a timeline.
Monitoring
We continue to work with AWS regional specialists, platform availability remains unchanged since our previous update.
AWS regional teams continue to make progress with their recovery efforts and continue to provide regular updates to our team. Our approach remains consistent with previous communications, and we will continue to monitor developments closely.
Our own parallel restoration efforts remain ongoing and we will consolidate all available information at the start of this week.
We will post further updates as information becomes available.
Monitoring
Platform availability remains unchanged since our previous update.
AWS regional specialists continue to make progress over the weekend with their recovery efforts and have been providing regular updates to our team. Our approach remains consistent with previous communications, and we will continue to monitor developments closely.
Our own parallel restoration efforts remain ongoing.
We will post further updates across the weekend as information becomes available, or if there is meaningful progress to report in the interim.
Monitoring
Platform availability remains unchanged since our previous update.
AWS regional specialists are continuing their infrastructure restoration work, and we remain in active contact with their team. We expect this work to continue through the weekend, and are targeting the start of next week to assess progress and make any further operational decisions.
Our own parallel restoration efforts remain ongoing.
We will post further updates across the weekend as information becomes available, or if there is meaningful progress to report in the interim.
Monitoring
There have been no major changes to platform availability since our last update. AWS regional specialists continue to work on restoration of their primary infrastructure, and we remain in close contact with their team. Our own restoration efforts are ongoing in parallel. We will post a further update as soon as there is meaningful progress to report.
Monitoring
We are continuing to experience a service disruption affecting platform availability in relation to the regional AWS outage in the UAE. Our team continues to work on alternative service restoration, and AWS regional specialists are engaged and working towards a resolution.
We will share an update when we have a clear view on whether we are clear to use the backup platform, or if AWS' experts are able to restore the affected services in our data centre.
Monitoring
We are continuing to experience a service disruption affecting platform availability in relation to the regional AWS outage. Our team continues to work on alternative service restoration, and AWS regional specialists are engaged and working towards a resolution.
No additional context has been shared overnight and we will share another update as soon as there is progress to report.
Monitoring
We are continuing to implement our internal resolution for the this ongoing ME regional issue.
We have effectively migrated the majority of our backup DB to an alternative service provider. This is a process we will continue to monitor with some outstanding reviews which will commence early morning on 5 March.
We have pending actions with our trade verification partners which will require updated connection points. Some of this requires re-direction from previously used data centers to alternatives, this will require some manual confirmation and when we have this we can make the adjustments relatively quickly to resume system functionality.
While we are confident in the way we have approached this situation and in the resolution we have worked towards, we are conscious of the changes that have been implemented and we will ensure that we complete system testing before declaring full system resolution.
We continue to work with regional experts from AWS to ensure that we have the most up to date information available and the best chances of successfully implementing our technical solutions, while maintaining data integrity within the region.
Monitoring
As part of this ongoing external issue we have been actively deploying our system restoration processes overnight. We understand that some of our systems are still affected by the ongoing regional issues, however our services are partially restored due to our internal recovery efforts.
Functionality may still be slightly impacted and we will continue to provide updates as the day progresses.
We will continue to monitor the situation and will release an update within the next 4 hours (Dubai 7pm)
Monitoring
We've resolved the issue and are now monitoring the fix.
Identified
Following the recent AWS outage affecting the UAE region, we have successfully deployed an alternative infrastructure solution to ensure continuity of service.
We are currently in the testing phase and expect to begin gradually enabling service resolution shortly. We will provide further updates as testing progresses. Please continue to monitor for service updates.
Identified
We are continuing to monitor AWS updates as they begin to report a partial restoration of some services in the region. We have nearly completed our parallel activity to restore a full environment separately to this. We will shortly be migrating data into this new environment and begin to test this restoration. We will provide an update in 2 hours (4:30 UTC / 8:30 GST)
Identified
We are continuing to monitor updates as they come in from AWS disaster relief efforts in the region, as we work on our own alternative internal resolution plans. We're progressing our steps to spin up our application in another region, but with our database (and S3) remaining in the UAE. To do this we've created an Azure DB in their UAE North region and are migrating a temporary data export.
Identified
We are continuing to manage the impact of the ongoing AWS outage in the me-central-1 (UAE) region. While the underlying infrastructure issues at AWS remain complex, our engineering team has shifted focus to a specific recovery path to restore our services independently.
We are now actively working on a fix to restore service. Based on current progress, we expect full restoration to take approximately 12 hours. We will continue to monitor the situation and provide updates throughout the day as we reach key milestones. The next update will be at 12:00 UTC / 4:00 PM GST
Identified
AWS are currently working towards restoring services in the UAE region. From their status page:
[06:22 AM PST] We continue to work towards recovery of the two impaired Availability Zones (mec1-az2 and mec1-az3) in the ME-CENTRAL-1 Region. We are expecting recovery to take at least a day, as it requires repair of facilities, cooling and power systems, coordination with local authorities, and careful assessment to ensure the safety of our operators. EC2, Amazon DynamoDB and other AWS Services continue to experience significant error rates and elevated latencies. We recommend customers enact their disaster recovery plans and recover from remote backups into alternate AWS Regions, ideally in Europe. Further, we strongly advise customers to update their applications to ingest S3 data to an alternate AWS Region. We will provide an update by 11:00 AM PST on March 2, or sooner if we have additional information to share.
Identified
There is an ongoing major incident with our hosting and services provider, AWS: AWS Incident Page
We are monitoring this incident closely and are aware that our API and Unity platform are affected in the UAE
Monitoring
Though AWS' outage in me-central-1 (AZ2) is still ongoing (AWS incident page here), we have identified that all of Ctrl Alt's systems are fully operational and not degraded
Investigating
We're investigating an issue with one or more of our internal or third party systems (AWS). We'll post an update once we've identified the cause and impact of the issue.