Website Offline in some regions
Resolved·Degraded performance

This issue has now been resolved. We apologise for any inconvenience.

Fri, Dec 5, 2025, 10:20 AM
(3 days ago)
·
Affected components
Website
Updates

Resolved

This issue has now been resolved. We apologise for any inconvenience.

Fri, Dec 5, 2025, 10:20 AM

Investigating

We're investigating an issue with one or more of our internal or third party systems. We'll post an update once we've identified the cause and impact of the issue.

Fri, Dec 5, 2025, 08:57 AM(1 hour earlier)
Powered by

ALT LTD (trading as 'Ctrl Alt') is a company Registered in England and Wales (company number 12481559) with a registered address of Alt Ltd, 86-90 Paul Street, London, England, EC2A 4NE.

Ctrl Alt Solutions DMCC (trading as 'Ctrl Alt') is a company registered in the UAE (company number DMCC199928) with a registered address of Ctrl Alt Solutions DMCC, Unit No: UT-12-PO-12, DMCC Business Centre, Level No. 12, Uptown Tower, Dubai, U.A.E.

Ctrl Alt Solutions DMCC (Ctrl Alt) is licensed by Dubai's Virtual Assets Regulatory Authority (VARA) for Broker Dealer Services since 24th May 2025 with VASP licence number VL/25/05/002

Don’t invest unless you are prepared to lose all the money you invest. This is a high risk investment. Alt Ltd facilitate the Ctrl Alt app. Alt Ltd (FRN: 974321) is an Appointed Representative of Infinity Asset Management LLP, a Firm authorised and regulated by the Financial Conduct Authority (FRN: 464315). Ctrl Alt does not provide investment advice and/or recommendations, and, no communication, through its App or website or otherwise, should be construed as a recommendation of any security. Individual investors should make their own decisions or seek professional independent advice if they are unsure as to the suitability / appropriateness of any investment for their individual circumstances or needs, including potential tax treatment. The value of an investment may go down as well as up and past performance is not a reliable indicator of future results. Access to this platform and the underlying assets is subject to eligibility. See our terms and conditions for further detail. Alt Ltd, 86-90 Paul Street, London, England, EC2A 4NE.

© Ctrl Alt – 2025